Digital Commerce Authentication Program

Digital Commerce Authentication Program

The Digital Commerce Authentication Program (DCAP) is an optional program that allows merchants to share additional data elements with issuers to improve acceptance rates and reduce fraud for customer-initiated, card-not-present transactions.

DCAP Market Availability

Currently available:

  • U.S. domestic card-not-present purchases‡
  • U.S. cross-border card-not-present purchases with issuers in Europe and Asia Pacific‡

Available October 23, 2026‡:

  • U.S. cross-border card-not-present purchases with issuers in all regions
  • Canada domestic and cross-border card-not-present purchases
  • U.S. and Canada domestic and cross-border AFTs*

DCAP does not apply to OCTs.‡

*While DCAP will be enabled for AFTs, AFT transactions will not receive DCAP rates. Visa is offering this additional expansion as a means to assess market interest in DCAP-enabled AFT transactions. DCAP rates on AFT transactions will be announced at a later date.

How TabaPay Supports DCAP

TabaPay currently supports tokenized DCAP transactions through VTS and non-tokenized transactions through 3DS on Visa consumer credit products for card-not-present purchase transactions.‡ No opt-in is required. Merchants can begin sending the below data elements at their discretion. Visa recognizes when these elements are received and applies the DCAP indicator.

As the acquirer, TabaPay will receive the DCAP indicator back in the authorization message indicating that these fields were received by Visa through either the VTS or 3DS rails. However, the indicator is only applied to transactions that met data quality requirements (see below). At this time, Visa does not specify a window of time for this review. Clients should continue to review their current reports.

DCAP Requirements

There are four required data elements for all DCAP transactions that will be assessed for correct formatting and quality. All elements must be present to qualify:

Data ElementDescriptionTypeExample
Device IDUnique and immutable identifier linked to a device.string [ 1 .. 64 ] charactersDevice-1234567890
IP AddressIP address the device is connecting from.string, IPv4 address (RFC 791) or IPv6 address (RFC 4291) [ 7 .. 45 ] characters2001:0db8:85a3:0000:0000:8a2e:0370:7334
Email AddressThe email address associated with the transaction.string, meeting Section 3.4 of IETF RFC 5322 [ 1 .. 254 ] characters[email protected]
Billing Address, line 1First line of the cardholder billing address associated with the card used for this purchase.string [ 1 .. 50 ] characters123 Main St
Billing Address, cityThe city of the cardholder billing address associated with the card used for this purchase.string [ 1 .. 50 ] charactersNew York
Billing Address, stateThe state of the cardholder billing address associated with the card used for this purchase. The value can be empty.string, country subdivision code defined in ISO 3166-2 [ 2 .. 3 ] charactersNY
Billing Address, postal codeZIP or other postal code of the cardholder billing address associated with the card used for this purchase.string [ 1 .. 16 ] characters10001

If any of the above are missing, or if an unacceptable value was observed by Visa, Visa may downgrade transactions and not add the DCAP indicator; repeatedly providing incomplete data or low-quality data can result in exclusion from DCAP.

Examples of poor data quality include generic emails like [email protected], placeholder phone numbers like +15555555555, or IP addresses such as unknown or N/A.

When a downgrade occurs, Visa currently provides no reporting to indicate the reason for the downgrade from DCAP rates. If clients have questions or concerns, TabaPay recommends reaching out to Visa directly.

DCAP Rates

  • Non-token DCAP transactions: 10 basis points (bps) interchange reduction, minus a 5 bps scheme fee, for a net savings of up to 5 bps per qualifying transaction.
  • Token DCAP transactions: 10 bps DCAP interchange reduction combined with ~5 bps Network Tokenization interchange benefit, minus a 5 bps scheme fee, for a net savings of ~10 bps per qualifying transaction.

Note: AFT DCAP transactions will not receive DCAP rates in October 2026. Visa is asking merchants to begin sending these enhanced data fields for AFT transactions to gather market data to support future DCAP program expansion.

‡Updated on 10/16/26

For additional questions, please contact [email protected].


Did this page help you?